Back to overview
Resolved

Mail Service is degraded

Sep 18, 2026 at 12:55am UTC
Affected services
Mail Service

Resolved
Sep 18, 2026 at 10:25pm UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 10:19pm UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 9:01pm UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 8:55pm UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 8:46pm UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 8:40pm UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 8:25pm UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 8:19pm UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 1:01pm UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 12:55pm UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 7:26am UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 7:19am UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 1:43am UTC

Mail Service recovered.

Updated
Sep 18, 2026 at 1:37am UTC

Mail Service is degraded.

Updated
Sep 18, 2026 at 1:01am UTC

Mail Service recovered.

Created
Sep 18, 2026 at 12:55am UTC

Mail Service is degraded.