Back to overview
Resolved

Mail Service is degraded

Sep 16, 2026 at 1:49am UTC
Affected services
Mail Service

Resolved
Sep 16, 2026 at 2:04pm UTC

Mail Service recovered.

Updated
Sep 16, 2026 at 1:58pm UTC

Mail Service is degraded.

Updated
Sep 16, 2026 at 10:26am UTC

Mail Service recovered.

Updated
Sep 16, 2026 at 10:19am UTC

Mail Service is degraded.

Updated
Sep 16, 2026 at 3:01am UTC

Mail Service recovered.

Updated
Sep 16, 2026 at 2:55am UTC

Mail Service is degraded.

Updated
Sep 16, 2026 at 1:55am UTC

Mail Service recovered.

Created
Sep 16, 2026 at 1:49am UTC

Mail Service is degraded.