Back to overview
Resolved

Mail Service is degraded

Sep 15, 2026 at 12:04am UTC
Affected services
Mail Service

Resolved
Sep 15, 2026 at 5:52pm UTC

Mail Service recovered.

Updated
Sep 15, 2026 at 5:46pm UTC

Mail Service is degraded.

Updated
Sep 15, 2026 at 3:07pm UTC

Mail Service recovered.

Updated
Sep 15, 2026 at 3:01pm UTC

Mail Service is degraded.

Updated
Sep 15, 2026 at 2:23pm UTC

Mail Service recovered.

Updated
Sep 15, 2026 at 2:16pm UTC

Mail Service is degraded.

Updated
Sep 15, 2026 at 8:04am UTC

Mail Service recovered.

Updated
Sep 15, 2026 at 7:58am UTC

Mail Service is degraded.

Updated
Sep 15, 2026 at 3:19am UTC

Mail Service recovered.

Updated
Sep 15, 2026 at 3:13am UTC

Mail Service is degraded.

Updated
Sep 15, 2026 at 2:37am UTC

Mail Service recovered.

Updated
Sep 15, 2026 at 2:31am UTC

Mail Service is degraded.

Updated
Sep 15, 2026 at 12:10am UTC

Mail Service recovered.

Created
Sep 15, 2026 at 12:04am UTC

Mail Service is degraded.