Back to overview
Resolved

Mail Service is degraded

Sep 14, 2026 at 4:22am UTC
Affected services
Mail Service

Resolved
Sep 14, 2026 at 11:55pm UTC

Mail Service recovered.

Updated
Sep 14, 2026 at 11:49pm UTC

Mail Service is degraded.

Updated
Sep 14, 2026 at 10:43pm UTC

Mail Service recovered.

Updated
Sep 14, 2026 at 10:37pm UTC

Mail Service is degraded.

Updated
Sep 14, 2026 at 8:55pm UTC

Mail Service recovered.

Updated
Sep 14, 2026 at 8:49pm UTC

Mail Service is degraded.

Updated
Sep 14, 2026 at 8:41pm UTC

Mail Service recovered.

Updated
Sep 14, 2026 at 8:34pm UTC

Mail Service is degraded.

Updated
Sep 14, 2026 at 7:34pm UTC

Mail Service recovered.

Updated
Sep 14, 2026 at 7:28pm UTC

Mail Service is degraded.

Updated
Sep 14, 2026 at 12:10pm UTC

Mail Service recovered.

Updated
Sep 14, 2026 at 12:04pm UTC

Mail Service is degraded.

Updated
Sep 14, 2026 at 4:28am UTC

Mail Service recovered.

Created
Sep 14, 2026 at 4:22am UTC

Mail Service is degraded.