Back to overview
Resolved

Mail Service is degraded

Sep 13, 2026 at 1:04am UTC
Affected services
Mail Service

Resolved
Sep 13, 2026 at 4:22pm UTC

Mail Service recovered.

Updated
Sep 13, 2026 at 4:16pm UTC

Mail Service is degraded.

Updated
Sep 13, 2026 at 9:16am UTC

Mail Service recovered.

Updated
Sep 13, 2026 at 9:10am UTC

Mail Service is degraded.

Updated
Sep 13, 2026 at 8:22am UTC

Mail Service recovered.

Updated
Sep 13, 2026 at 8:16am UTC

Mail Service is degraded.

Updated
Sep 13, 2026 at 6:37am UTC

Mail Service recovered.

Updated
Sep 13, 2026 at 6:31am UTC

Mail Service is degraded.

Updated
Sep 13, 2026 at 5:44am UTC

Mail Service recovered.

Updated
Sep 13, 2026 at 5:37am UTC

Mail Service is degraded.

Updated
Sep 13, 2026 at 1:11am UTC

Mail Service recovered.

Created
Sep 13, 2026 at 1:04am UTC

Mail Service is degraded.